吾愛破解 - LCG - LSG |安卓破解|病毒分析|破解軟件|www.dypczhxn.cn

 找回密碼
 注冊[Register]

QQ登錄

只需一步,快速開始

搜索
查看: 278|回復: 9
上一主題 下一主題

[已解決] 易語言更新sql某個字段數值問題

 關閉 [復制鏈接]
跳轉到指定樓層
樓主
tsf475050491 發表于 2019-9-12 11:22 回帖獎勵
本帖最后由 tsf475050491 于 2019-9-15 11:53 編輯

現在遇到一個問題,我想更新sqlserver A表empj01字段的數值=empj01+編輯框里面的數值,怎么改都修改不了,求大神指教
[SQL] 純文本查看 復制代碼
.版本 2
.支持庫 eDB

sql語句1 = “update hr_employee set empje01='empje01' + '” + 刪首尾空 (金額編輯框.內容) + “' WHERE empno='” + 編號編輯框.內容 + “'”
sql語句2 = “update dlc_record_xf set xfmoney='0' WHERE empno='” + 編號編輯框.內容 + “'and skdate='” + 日期編輯框.內容 + “'and xftime='” + 時間編輯框.內容 + “'and xfmoney='” + 金額編輯框.內容 + “'”
.如果 (信息框 (“【警告】數據將被修改!”, 1, , ) = #確認鈕)

.否則

    ' 否則 ()
    返回 ()
.如果結束
.如果 (編號編輯框.內容 = “”)
    信息框 (“編號編輯框.內容為空!”, 0, , )
.否則
    .如果真 (數據庫連接1.執行SQL (sql語句1, ))
        信息框 (“更新成功!”, 0, “溫馨提示”, )
    .如果真結束
    返回 ()
    信息框 (“失敗”, 0, , )



.如果結束
返回 ()



感謝各位大佬的幫助,軟件已經編譯成功了,對接的是sqlserver2008數據庫查詢

發帖前要善用論壇搜索功能,那里可能會有你要找的答案或者已經有人發布過相同內容了,請勿重復發帖。

沙發
sinewtec 發表于 2019-9-12 11:27
易語言要注意語句中的空格
3#
 樓主| tsf475050491 發表于 2019-9-12 12:18 <
4#
 樓主| tsf475050491 發表于 2019-9-12 12:19 <
sinewtec 發表于 2019-9-12 11:27
易語言要注意語句中的空格

[Asm] 純文本查看 復制代碼
sql語句1 = “update hr_employee set empje01='empje01' + '” + 刪首尾空 (金額編輯框.內容) + “' WHERE empno='” + 編號編輯框.內容 + “'”



就這條語句執行不成功,我在數據庫查詢窗口執行沒問題
5#
diyikuai 發表于 2019-9-12 12:31
調試出來是這個結果,我不清楚你數據庫操作語句是怎么寫的,不過調試結果我覺得有問題

QQ圖片20190912123049.png (101.5 KB, 下載次數: 0)

QQ圖片20190912123049.png
6#
小可愛~ 發表于 2019-9-12 13:31
你確定沒問題?
[SQL] 純文本查看 復制代碼
UPDATE hr_employee
SET empje01 = 'empje01' + 'zhazha'
WHERE empno = 'hoho'

” + 刪首尾空 (金額編輯框.內容) + “

我給替換成 zhazha   了

'empje01' + 'zhazha'
上面這個是什么鬼?
7#
Monitor 發表于 2019-9-12 13:47
引號問題吧
8#
haduke 發表于 2019-9-12 14:15
看一下sql語句1里就有錯誤:update hr_employee set empje01='empje01'
=號后面empje01不能有單引號
9#
 樓主| tsf475050491 發表于 2019-9-12 14:49 <
haduke 發表于 2019-9-12 14:15
看一下sql語句1里就有錯誤:update hr_employee set empje01='empje01'
=號后面empje01不能有單引號

可以了,謝謝
[SQL] 純文本查看 復制代碼
sql語句1 = “update hr_employee set empje01=empje01 + '” + 刪首尾空 (金額編輯框.內容) + “' WHERE empno='” + 編號編輯框.內容 + “'”


順便在幫我看看第二條,沒有執行成功
[SQL] 純文本查看 復制代碼
sql語句2 = “update dlc_record_xf set xfmoney=0 WHERE empno='” + 編號編輯框.內容 + “'and skdate='” + 日期編輯框.內容 + “'and xftime='” + 時間編輯框.內容 + “'and xfmoney='” + 金額編輯框.內容 + “'”
10#
 樓主| tsf475050491 發表于 2019-9-12 15:00 <
tsf475050491 發表于 2019-9-12 14:49
可以了,謝謝
[mw_shl_code=sql,true]sql語句1 = “update hr_employee set empje01=empje01 + '” +  ...

第二條沒問題,我的字段標示寫錯了
您需要登錄后才可以回帖 登錄 | 注冊[Register]

本版積分規則 警告:禁止回復非技術或與主題無關水貼,違者重罰!

快速回復 收藏帖子 返回列表 搜索

RSS訂閱|小黑屋|聯系我們|吾愛破解 - LCG - LSG ( 京ICP備16042023號 | 京公網安備 11010502030087號 )

GMT+8, 2019-10-17 16:08

Powered by Discuz!

© 2001-2017 Comsenz Inc.

快速回復 返回頂部 返回列表
现在靠网络挣钱的方法